iSCSI Cake Manual

CCDISK用户手册

服务端使用说明

CCDISK 包含2部分：
1.NT服务 ： CakeService.exe在计算机启动后自动后台运行。
2.用户界面 ：iSCSICake.exe和ControlClient.dll提供用户界面，可以设置服务器和查看服务器状态。

安装过程很简单，一直按“下一步”到结束就完成了安装。通过运行桌面或者快速启动工具栏里面的快捷方式启动用户界面。首先看到的是登录密码框，初始密码为空。如果管理员密码为空，只能在服务器本机控制。设置了管理员密码后就可以把iSCSICake.exe和ControlClient.dll拷贝到任何计算机来控制服务器。

下面的图显示的是主界面：
1.添加磁盘：添加iSCSI磁盘。
2.添加客户：添加新客户。默认设置是自动添加客户。如果iSCSI盘不是默认盘，则需要手动添加客户。
3.删除磁盘：删除iSCSI磁盘。
4.删除客户：删除客户。例如当观察到客户流量异常时可以手动删除该客户。
5.修改设置：修改服务器设置。
6.更新缓存：在服务器更新数据后需要刷新缓存。如果是用超级客户端更新数据，缓存会自动刷新，不需要手动刷新缓存。
7.启动服务：启动iSCSI服务。
8.停止服务：停止iSCSI服务。
9.退出界面：退出用户界面，后台服务仍然在运行。
10.版本信息：版本信息和注册软件。

点击“添加磁盘”，弹出磁盘属性设置对话框：
1.磁盘名：磁盘名字。
2.容量：源盘的容量。
3.工作目录：用来存放客户数据文件 。
4.存储资源：用来共享的分区或者物理磁盘。
5.启动类型：默认为自动，服务启动时磁盘自动启动。
6.默认盘：选上则自动添加客户。
7.允许超级客户端：允许客户从客户端更新数据。如果存储资源是分区，当iSCSI磁盘运行时，本机不能访问该分区。如果存储资源时物理磁盘，需要手动在磁盘管理里面删除该磁盘上的所有盘符。（注意：是删除盘符不是删除分区，删除分区会造成无法挽回的数据破坏。）停止iSCSI磁盘或者禁用超级客户端后可以再把盘符恢复。

点击OK返回主界面。这时磁盘的状态应该为运行，你可以右键点击该磁盘查看属性或者修改设置。当磁盘正在运行时不能修改其属性。磁盘的状态包括速度，运行时间和读写流量，可以用来监视服务器运行情况。

CCDISK的默认设置适用于绝大多数情况，当然你也可以点击“修改设置”来修改服务器设置：
1.服务端口：默认3269。
2.超级缓存大小：服务端缓存大小，单位为兆字节。
3.小请求加速：加快小请求相应速度。
4.状态刷新时间：状态刷新时间间隔，单位为秒。
5.控制端口：用来和用户界面通讯的端口。
6.管理员密码：用户界面登录的密码。
7.超级客户端密码：超级客户端密码，长度为12－15位。客户端通过打开高级选项里面的CHAP选项输入密码。
8.[客户端设置]：下面的设置需要在客户端安装本地缓存配合使用。
9.启用本地缓存：是否启用本地缓存，缓存大小单位为兆字节。
10.内存缓存：用客户端的内存做缓存。
11.磁盘缓存：用客户端的磁盘做缓存，需要指定缓存目录。
12.客户关机时保存数据到服务器：客户断开时把缓存里面的数据刷新到服务器。
13.只缓存写请求：只缓存写请求，不缓存读请求。

Tanky 2007.03.22

http://www.ccdisk.com

email：support@ccdisk.com


微软iSCSI客户端使用指南

微软为了支持iSCSI应用，提供了标准的iSCSI客户端，也叫iSCSI启动器，可以从微软的网站下载。下面以1.06版本为例来讲解微软客户端的安装和使用。

注：1.06版的微软客户端只支持XP/2000/2003系列操作系统，不支持98/ME。

下载的文件名为1.06-initiator-x86fre.msi，运行后出现安装界面如图1：

图1 开始安装界面

选择“Next>”，再选择安装目录，继续“Next>”，知道出现授权协议界面如图2，选择“I Agree”，再“Next>”。

图2 软件授权界面

闪过一段进度条后弹出选择需要安装的组件界面如图3，不用改设置，选择OK继续，然后又是一个授权协议，选择“Agree”。

图3 安装组件选择

如果安装顺利将出现安装成功的提示，如图4，最后是恭喜的信息，选择“Next”->“Close”结束安装。

图4 安装成功提示

安装成功后在桌面生成一个图标，如图5：

图5 客户端快捷方式

双击图标运行客户端，出现客户端界面，如图6，选择“Add”添加服务器地址。

图6 客户端主界面

在弹出的对话框中填入服务器IP地址，如图7，Socket为3260，点击OK确定。

图7 添加服务器地址

添加服务器的过程需要大概30秒钟左右的时间，然后返回主界面，点击“Available Targets”可以看到添加的服务器的iSCSI名字，如图8：

图8 添加成功的服务器的名字

选择“Log On”登录服务器，弹出登录对话框，如图9：

图9 登录服务器

小提示：如果选择了“Automatically restore...”，客户机以后重启的时候会自动连接服务器。如果想取消自动连接，在“Persistent Targets”里面把服务器删除。

如果登录成功服务器的状态“Status”将由Inactive变为“Connected”，在“Active sessions ”里面可以看到建立的连接，如图10：

图10 连接的状态

建立连接后可以在磁盘管理里面看到新添加的磁盘，如图11。其中磁盘1就是新出现的iSCSI磁盘，上面有一个分区J:。

图11 磁盘管理

点击图10中的“Log Off”可以断开与服务器的连接。

小提示1：一般新的磁盘会在“我的电脑”里面显示出来，但也有的时候客户端的操作系统不自动为这个新的磁盘分配盘符，这时可以在新的分区上点击鼠标右键，选择“更改驱动器名和路径”，为新的分区分配一个盘符。

小提示2：最好不要将服务器和客户端装在同一台计算机上

Tanky 制作 2005.4


ccdisk超级客户端使用方法

CCDISK用户手册

超级客户端使用说明


常见问题

  1. iSCSI协议简介?
  2. iSCSI Cake是什么?
  3. iSCSI Cake最大的优点是什么?
  4. iSCSI Cake还有什么优点?
  5. iSCSI Cake与网络邻居共享有什么不同?
  6. iSCSI Cake适合在什么场合使用?
  7. iSCSI Cake可以单独使用吗?
  8. 什么是默认盘?
  9. 加载磁盘时间长否
  10. 每个客户端有设置文件保存的功能，是不是保存下面机器的东西啊？
  11. 机器重起后是否又加载本机器写的数据了？？？
  12. 那保存是否加载磁盘要快点？
  13. 我想知道就是，如果我先设置为保存，然后下面客户机修改后，我要还原是不是选择不保存，就自动还原了？
  14. 我改成不保存后，服务器生成的文件是否能删除，是自动删除，还是要手动删除？
  15. 微软客户端命令说明下载
  16. 客户端必须开哪些服务？
  17. 怎样防止启动的时候自动弹出虚拟盘？
  18. 添加盘的时候，选择默认和不选择有什么区别？
  19. 服务器端内存消耗如何？
  20. 我为iscsicake工作目录准备了个5G的分区，使用时看到只剩500M了。我设置的是不保存。为什么？
  21. 请问客户端怎么保存数据？
  22. 是不是这个客户端有了数据，别的机器开起来虚拟的D盘也就有了数据？
  23. 是不是所有的客户端都要单独保存？不能共用一个镜像？
  24. 原始的数据是从服务端加么？那以后更新游戏怎么办？
  25. 我现在在服务端加个文件，客户端重启就能看到了？是不是？
  26. 那如果在网吧里有的是需要安装的游戏怎么办呢？
  27. iSCSI Cake的传输速度是多少？
  28. 游戏要读注册表怎么办？
  29. 客户端虚拟盘符出不了怎么办？
  30. 推荐系统硬件配置
  31. 和哪些硬件或者软件不兼容
  32. 为什么一个客户只能用一个盘
  33. 请问最大可以支持多大的容量
  34. 为什么我设置不保留的，无论是客户端重启还是服务端重启,文件都保留着
  35. 我以前用老版本可以出现盘符，用新版本为什么盘符不见了（或者每次都要查找新硬件）
  36. 我用的是1.3版，为什么服务器更新数据后客户机重新连接还是看不到新数据
  37. 我用的是windows自带的软阵列，客户端不能自动分配盘符是为什么
  38. 为什么杀毒软件报告iSCSI Cake是病毒
  39. iSCSI Cake日志解释
  40. 1.3版的缓存设置多大合适
  41. 我的服务器系统是2003，安装sp1以后程序运行出错，什么原因
  42. 为什么我的客户机一玩魔兽游戏就死机？
  43. 工作目录设置多大，放置在哪里比较合适。
  44. 为什么我的客户端连接速度非常慢，出盘符的时间很长？
  45. 为什么我设置了客户端保存，服务端的文件还是没有变化？
  46. 为什么我用了ISCSI CAKE 1.3版本后内存占用非常大？
  47. 使用超级客户端更新数据的步骤是怎样的？
  48. 为什么用超级客户端更新数据后服务器自己看不到？
  49. 用超级客户端更新数据后还能直接在服务器上更新数据吗？
  50. 为什么我用超级客户端更新后，服务器重启时显示磁盘文件损坏，需要检查磁盘？
  51. 为什么运行CCDISK服务端或本地缓存客户端屏幕不断刷新，无法出使用界面？
  52. 为什么客户端连接后无法使用虚拟盘,每次都要手动激活后才可以使用?
  53. 为什么服务器游戏更新后,客户端无法看到更新?
  54. 诺顿11月10日病毒库报毒的解决方法。

iSCSI协议简介

iSCSI协议是当前最HOT的网络存储协议，可以解决SCSI协议在连接的设备数目和连接距离方面的限制。用户可以像使用本地的硬盘一样访问网络上任何位置的存储资源，也可以将原有的旧的分散的存储资源整合成一个大的存储池

iSCSI Cake是什么?

iSCSI Cake是一个存储服务器，可以把服务器的存储资源提供给客户机使用，客户机可以像使用本地硬盘一样使用iSCSI磁盘，包括对其进行分区，格式化，读写。

iSCSI Cake最大的优点是什么?

就是超级保护。每个客户都可以往iSCSI磁盘写数据，互不干扰，而且不会破坏服务器的数据。每个客户只占用很少的服务器磁盘空间。

iSCSI Cake还有什么优点?

速度快，对用户权限控制非常灵活，支持配置文件，自动启动，支持所有客户端的游戏，和数据库应用。

iSCSI Cake与网络邻居共享有什么不同?

网络邻居是文件级共享，iSCSI是裸设备级共享。网络邻居映射的盘不支持数据库和运行某些游戏，iSCSI支持所有磁盘操作和应用程序。而且iSCSI Cake的性能要高于网络邻居。

iSCSI Cake适合在什么场合使用?

在网吧或者机房，网络管理员不需要在每个机器安装软件和游戏，只需要把服务器的资源通过iSCSI Cake共享出来给客户使用，客户可以任意对数据进行修改、删除操作，不会影响服务器数据。

iSCSI Cake可以单独使用吗?

不行。iSCSI Cake只是服务器，必须和客户端(也叫启动器)一起使用。推荐使用微软提供的客户端(1.06-initiator-x86fre.msi)，可以从这里下载:
http://www.microsoft.com/downloads/details.aspx?FamilyID=12cb3c1a-15d6-4585-b385-befd1319f825&displaylang=en

什么是默认盘?

有时候系统里面有很多客户机，管理员不想把客户一个个地加入配置文件，也不想对用户访问进行控制。这时就可以添加一个默认盘，所有没有加入访问控制列表的用户就都可以访问这个默认盘了。当然已经加入访问控制列表的客户访问的还是设定的iSCSI盘。

加载磁盘时间长否

最快一秒多，最慢4－5秒。如果用物理盘模式，而且上面有很多分区的话，第一次连接系统会花稍微长一点的时间扫描磁盘信息。盘符出来以后就和本地硬盘速度一样了，100M网，120台机子同时跑时 ,其中30多台在跑天堂2。

每个客户端有设置文件保存的功能，是不是保存下面机器的东西啊？

如果设置了保存客户数据，客户写的数据会保存在服务器上的工作目录下，下次客户连接还可以看到自己写的数据，但是不会修改服务器的数据。目前iSCSI Cake不支持从客户端更新服务器的数据。

机器重起后是否又加载本机器写的数据了？？？

如果选择了保存客户数据，客户下次重启自动连接后会加载以前的数据。

那保存是否加载磁盘要快点？

速度是一样的

我想知道就是，如果我先设置为保存，然后下面客户机修改后，我要还原是不是选择不保存，就自动还原了？

是的，不过客户机需要重新连接

我改成不保存后，服务器生成的文件是否能删除，是自动删除，还是要手动删除？

客户断开连接时服务器会自动删除客户文件

微软客户端命令说明下载

点击这里下载 （英文版）

客户端必须开哪些服务？

Protected Storage
Windows Management Instrumentation Driver Extensions
这2个服务一定要开，最好设为自动

Security Accounts Manager
Distributed Transaction Coordinator
这2个服务有的客户反映一定要开，但是有的客户不开也可以用

怎样防止启动的时候自动弹出虚拟盘？

1）如果用万象网吧管理软件，有界面模式就不会弹出窗口。(感谢网友我是谁提供)
2）如果安装了PUBWIN和净网先锋就不会再弹出来了。(感谢网友Tim提供)
3）如果将虚拟盘符隐藏，也可以实现不自动弹出窗口。(感谢网友MiCkEy.Z提供)
4）如果是XP系统在开始运行里输入gpedit.msc,在计算机配置里选系统，把右边的关闭自动播放策略启用。
5）如果是2000系统，把以下2个服务设置为自动：
Remote Procedure Call (RPC) 自动
Remote Procedure Call (RPC) Locator 自动
重起机器就可以了。

添加盘的时候，选择默认和不选择有什么区别？

选择默认盘就不用一个个添加客户了

服务器端内存消耗如何？

计算机多了就耗点，平均每用户占1.5M内存

我为iscsicake工作目录准备了个5G的分区，使用时看到只剩500M了。我设置的是不保存。为什么？

客户都在连接的时候，就会在工作目录中有一个客户文件，文件大小和客户往磁盘写的数据多少有关，如果没有选择保存客户数据，客户断开时这个文件就会被自动删除。

请问客户端怎么保存数据？

添加客户时选择保存数据。
注意这个选项并不会修改服务器的数据，而是单独放在客户文件里。目前这个版本客户可保存的数据总量为2G，最好不要在客户端安装超大型的游戏。
目前iSCSI Cake1.4不支持从客户端更新服务器的数据。

是不是这个客户端有了数据，别的机器开起来虚拟的D盘也就有了数据？

一个客户保存的数据只能自己看到

是不是所有的客户端都要单独保存？不能共用一个镜像？

是公用一个原始的数据，但是客户修改的数据单独存放

原始的数据是从服务端加么？那以后更新游戏怎么办？

直接在服务器更新，客户最好不要保存数据，下次连接服务器就看到的是新数据了

我现在在服务端加个文件，客户端重启就能看到了？是不是？

是的，重新连接就可以了，不用重启

那如果在网吧里有的是需要安装的游戏怎么办呢？

只要是硬盘拷贝能用的游戏就可以

iSCSI Cake的传输速度是多少？

100M网络平均值为8M/s

游戏要读注册表怎么办？

用讯闪就可以搞定。详细介绍看这里 http://bbs.txwm.com/dispbbs.asp?boardID=190&ID=237493

客户端虚拟盘符出不了怎么办？

这种情况一般出现在简装版的XP操作系统上，这种情况下，你需要将iSCSI的磁盘模式改为物理盘模式。

推荐系统硬件配置

主板865PE/CPU P4 3.0E/内存1G/硬盘80G 8M SATA

和哪些硬件或者软件不兼容

服务端2003＋sp1不能运行(已经解决该问题)
服务端AMD 64位CPU可能会不兼容，但是也有客户正常使用(已经解决)。

为什么一个客户只能用一个盘

分区模式下，目前的iSCSI Cake1.4不支持多盘，以后的版本会加入这个功能。如果要实现多盘，您可以将ccdisk里的模式改为物理盘模式。

请问最大可以支持多大的容量

iSCSI Cake最大支持2T的磁盘容量。
客户可以保存的数据总量是2G，所以最好不要在客户端安装超大型的游戏。

为什么我设置不保留的，无论是客户端重启还是服务端重启,文件都保留着

你的log里面有两种和文件有关的错误，一个是工作目录满了，还有一个是客户写的文件太多了，超过了2G。建议
1.你把服务机器重新启动一下，把工作目录下的文件手动删除，再重新运行程序。
2.工作目录所在的盘剩余空间要留大一点。
3.定期做磁盘碎片扫描。

我以前用老版本可以出现盘符，用新版本为什么盘符不见了（或者每次都要查找新硬件）

有些客户以前可以出现盘符，升级后盘符出不了是因为磁盘名字变了，同时也和精简的xp有关系。以前的版本磁盘名带版本号，这样1.1的升级到1.2就会磁盘名字不一样，为了解决这个问题，最新的版本在磁盘名中去掉了版本号，以后不会再变，但这样又和老的1.2版的磁盘名不一样，所以又会有部分精简XP出现这个问题。如果是老的1.2的版本，可以在新版本里的“查看”->“设置”里面选择“旧磁盘名”，如果是1.1的版本，请和我们联系。下次做母盘时记得用新版的(5月21号以后的版本)。

我用的是1.3版，为什么服务器更新数据后客户机重新连接还是看不到新数据

1.3版添加了超级缓存功能，用了超级缓存以后，服务器更新数据后,客户重新连接也不会马上看到，因为有部分数据在服务器缓存里，可以进入“查看”->“设置”，点击更新缓存，或者点击工具条上的“更新缓存”，这样客户重新连接看到的就是新数据了。

我用的是windows自带的软阵列，客户端不能自动分配盘符是为什么

目前iSCSI Cake的版本对软阵列的支持不是很好，特别是大容量的软阵列，有时候客户端不能自动分配盘符，推荐使用硬阵列或者物理盘模式。

为什么杀毒软件报告iSCSI Cake是病毒

应该是有病毒或木马用了和iSCSI Cake相同的壳加密，被发现后，反病毒技术人员很草率地用壳的特征码当作病毒或木马的特征码，结果是错杀一大堆。不过为了安全起见，如果杀毒软件报告有病毒的话，大家还是用多种杀毒软件检查一下(MACFEE会误报）iSCSI Cake。

iSCSI Cake日志解释

iSCSI Cake日志解释

1.3版的缓存设置多大合适

这要根据计算机内存来设置，计算方式为： 总内存＝600M系统＋2M×客户数＋缓存
推荐安装2G内存，分配1G做iSCSI的缓存。

我的服务器系统是2003，安装sp1以后程序运行出错，什么原因

本软件所使用的加密的壳和2003sp1不兼容，所以导致程序运行异常，比如CPU占用率100％，如果要使用2003的话，最好不安装sp1。
该问题已经解决,请需要的正版用户请更新到新版.

为什么我的客户机一玩魔兽游戏就死机？

这是跟客户机安装了DEEP还原软件有关，卸载DEEP就可以了。

工作目录设置多大，放置在哪里比较合适。

ISCSI CAKE正式版默认安装的位置在C盘，工作目录默认在安装目录下的DISK1目录里，建议最好不要放在C盘，单独划个区做工作目录，
并且有个要求，如果是用区模式，不要和资源区同一个分区；如果是用物理盘模式，不要和资源盘同一个硬盘。大小可以建议一个客户端安排150M，（因为客户端对虚拟盘的改变会引起工作 目录的IP文件变大）。

为什么我的客户端连接速度非常慢，出盘符的时间很长？

客户端出现连接速度慢有2个原因
1：客户端的系统没有做好，建议换个母盘做系统（系统安装盘最好也换，很多精简版的系统和微软的ISCSI驱动不兼容，会出现奇怪的现象）
2：把ISCSI CAKE的工作目录设置在资源盘或资源区，降低了磁盘读写速度。建议把工作目录和资源盘放在不同的磁盘上。

为什么我设置了客户端保存，服务端的文件还是没有变化？

客户端的保存功能，只是把对虚拟盘的改变写到服务器工作目录（DISK1）里的工作文件，不会对共享的资源产生任何改变，超级终端我们将会在下一版本提供，界时就可以在客户端对服务器游戏进行升级。

为什么我用了ISCSI CAKE 1.3版本后内存占用非常大？

因为1.3版本自带超级缓存，不需要第三方的缓存软件，您设置了多大给超级缓存，就额外占用多少内存。
软件内存占用总量＝软件自身运行所需要的内存＋缓存大小。

使用超级客户端更新数据的步骤是怎样的？

1.添加一个客户端，选择超级客户端属性。
2.启动超级客户端机器（或者重新连接）。
3.从客户端往ISCSI盘里面更新数据。
4.断开客户端（或者重启）以保证数据完全写到服务器，就像拔出USB盘之前要安全删除一样。
5.其他客户端重新连接（或者重启）就可以看到最新的数据了。

为什么用超级客户端更新数据后服务器自己看不到？

超级客户端是工作在windows的文件系统之下的，直接修改服务器上共享磁盘的内容，服务器文件系统不知道磁盘内容改变了，所以在资源管理器里面看不到共享盘更新的数据。但是对客户端没有影响，客户端只要重新连接就能看到最新的数据了。
服务端计算机重启后能在资源管理器里面看到最新的数据。

用超级客户端更新数据后还能直接在服务器上更新数据吗？

不行，服务器自己看不到超级客户端更新的数据，如果这时在服务器往共享盘写数据会导致数据损坏。如果想改为服务器更新方式，需要重新启动服务器，并且停止使用超级客户端。
推荐使用服务器直接更新，比如采用网络邻居或者ftp更新。

为什么我用超级客户端更新后，服务器重启时显示磁盘文件损坏，需要检查磁盘？

这是因为在用超级客户端更新数据后，又人为的直接在服务器往共享盘写了数据，或者是服务器上其他程序往磁盘写了数据，导致文件系统不一致，请不要跳过检查磁盘，系统会自动修复问题。

为什么运行CCDISK服务端或本地缓存客户端屏幕不断刷新，无法出使用界面？

请在系统的C盘根目录下BOOT.INT文件做下修改：

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=alwaysoff

为什么客户端连接后无法使用虚拟盘,每次都要手动激活后才可以使用?

服务端的资源盘如果采用动态盘就会出现这种情况,请转换为基本盘.转换前请做好数据备份工作.

为什么服务器游戏更新后,客户端无法看到更新?

1.3版后,服务器游戏增加或更新后,要手动更新缓存(点击绿色双箭头的按钮),客户端重新连接或重新启动就可以看到更新的内容.

诺顿11月10日病毒库报毒的解决方法。

打开诺顿主程序界面，点“配置”，选折里面的“文件系统实时保护”，把右边的“排除文件和文件夹”打钩，在点“排除”选项。

再点里面的“扩展名”，添加EPE文件类型扩展名，确定退出就可以了。